hagga_blog ist zurück!

So liebe Leser. Das hagga_blog ist endlich wieder zurück!

Leider hat das länger als geplant gedauert.
Es war auch nicht geplant, dass es überhaupt offline geht. Das war alles eine ziemliche Verkettung blöder Umstände.

Und zwar kam das so: Bislang lief das hagga_blog ja auf meinem V-Server von NoDeeps. Auf einem V-Server ist man ja selbst für die Software verantwortlich. Also dachte ich mir, mache ich doch mal ein Software-Update, um gegen die neuesten Sicherheitslöcher gefeit zu sein. Also mal flugs “apt-get upgrade” eingetippt und ne Fehlermeldung bekommen. Irgendein Paket könne nicht deaktiviert werden, was aber notwendig sei, um zu aktualisieren.

Also hab ich mal bei Google nach der Meldung gesucht und auch ne Lösung gefunden.
Als ich diese dann ausprobierte, passierte etwas unerwartetes. Er schlug vor, ziemlich viele Software-Pakete zu löschen. Ich dachte mir, mmh, nicht gut, aber wenn das sein muss, um die zu aktualisieren, dann wird’s schon ok sein.

So hab ich dem dann zugestimmt und selbst persönlich fast die gesamte Software auf dem V-Server gelöscht. Unter anderem MySQL, den Mailserver und sogar sowas wie rm, ls

Besonders letztere Tools sind notwendig, damit apt-get die Software wieder installieren kann.

Ich hab dann auch noch ein wenig rumprobiert und mir ls, rm, etc. von meinem Linux zu Hause hochgeladen (SFTP ging zum Glück noch). Aber wirklich geholfen hat das nicht. Er wollte nix installieren.

Also hab ich mich entschlossen, ein Backup meiner Daten zu machen. Vorallem der DB des hagga_blogs. Leider stand mir dazu weder phpMyAdmin noch mysqldump auf der Shell zur Verfügung. Beides war ja gelöscht. Also musste ich das Verzeichnis, in dem MySQL seine Daten ablegt, so runterladen und zu Hause konvertieren.

Ich hab mir nämlich noch am gleichen Tag ein neues Webhosting-Paket zugelegt. Diesmal wieder managed. Hab die Schnauze voll von V-Servern… Dort kann man die DB aber nur via phpMyAdmin füttern, also musste ich das konvertieren. Das ging aber.

Warum das hagga_blog aber erst jetzt wieder erreichbar ist, also 2 Wochen nach dem Unfall, liegt daran, dass der KK der Domain mal wieder nicht geklappt hat.
Immer wenn ich mit einer Domain zu einem anderen Provider umziehen will, gibt es Probleme.

Diesmal war NoDeeps wohl der Schuldige. Hatte denen direkt noch an dem Sonntag vor zwei Wochen den KK-Antrag unterschrieben zugefaxt. Die meinten aber, die hätten keinen erhalten. Also hab ich den, nachdem ich das nach mehreren Tagen von denen erfahren habe, am Freitag noch per Post dahin geschickt. Dann hat es aber noch mal bis Mittwoch gedauert, wo dann ne Bestätigung kam, dass sie das erhalten haben.
Mein neuer Provider (publicompserver) bekam aber kein ACK für den KK. Also musste ich beiden Seiten noch mehrere Mails schicken, bis das heute, am Samstag, also 13 Tage später endlich geklappt hat.

Echt alle nur unfähig…

Ich konnte auch nichtmal auf dem V-Server eine Seite aufsetzen um euch zu informieren, was mit dem hagga_blog ist, denn erst war der Server gar nicht mehr zu erreichen (nachdem ich Neuinstallation beantragt hatte), dann ging zwar ein ping wieder, aber ein einloggen per SSH ist bis heute nicht möglich. Der Support hat auch noch nicht geantwortet oder was dagegen unternommen.
Saftladen!

Ich hoffe wirklich, dass das mit dem neuen Provider jetzt mal besser läuft.

So, nun weiterhin viel Spaß beim Lesen des hagga_blog!

2 Gedanken zu „hagga_blog ist zurück!“

  1. Pingback: hagga_blog Podcast » Blog Archive » hagga_blog Podcast wieder da

Kommentar verfassen